Polpid's World

[Gradle]Ubuntu 에서 Gradle 설치하기 본문

Development/Build

[Gradle]Ubuntu 에서 Gradle 설치하기

폴피드 2018.10.19 10:31

Ubuntu 에서 gradle 설치를 해보자.

설치 방법은 정말 간단하다.

sudo apt-get install gradle

$ sudo apt-get install gradleReading package lists... DoneBuilding dependency tree Reading state information... DoneThe following additional packages will be installed:

이렇게 하면 설치가 쭉~~ 시작된다.

gradle -v------------------------------------------------------------Gradle 2.10------------------------------------------------------------Build time: 2016-01-26 15:17:49 UTCBuild number: noneRevision: UNKNOWNGroovy: 2.4.5Ant: Apache Ant(TM) version 1.9.6 compiled on July 20 2018JVM: 1.8.0_181 (Oracle Corporation 25.181-b13)OS: Linux 4.15.0-1021-gcp amd64

흠... 그런데... gradle 버전이 좀 이상하다.....

2.10?????

난 4 버전을 설치하고 싶은데.. 어떻게 해야하나.

sudo add-apt-repository ppa:cwchien/gradle
sudo add-apt-repository ppa:cwchien/gradle

sudo add-apt-repository ppa:cwchien/gradle

먼저 repository 를 추가한다.

그리고 sudo apt-get update 한번 쳐준다. 

sudo apt-get install gradle-4

여기까지 치고 TAB 키를 누르면

sudo apt-get install gradle-4.gradle-4.10 gradle-4.10.1 gradle-4.10.2 gradle-4.6 gradle-4.7 gradle-4.8.1 gradle-4.9

이렇게 설치할 수 있는 종류가 나온다.

나는 4.6 버전 선택해서 인스톨을 진행 했다.

gradle -v------------------------------------------------------------Gradle 4.6------------------------------------------------------------Build time: 2018-02-28 13:36:36 UTCRevision: 8fa6ce7945b640e6168488e4417f9bb96e4ab46cGroovy: 2.4.12Ant: Apache Ant(TM) version 1.9.9 compiled on February 2 2017JVM: 1.8.0_181 (Oracle Corporation 25.181-b13)OS: Linux 4.15.0-1021-gcp amd64

이렇게 설치를 마무리 하면 된다.



'Development > Build' 카테고리의 다른 글

[Gradle] gradle build error tool.jar... valid JDK  (0) 2018.10.19
[Gradle]Ubuntu 에서 Gradle 설치하기  (0) 2018.10.19
Jenkins 설치  (0) 2018.09.19
Mac 에서 gradle 설치  (0) 2016.07.04
Maven 라이브러리 추출  (0) 2016.01.06
Maven clean, install, build??  (0) 2015.05.12
0 Comments
댓글쓰기 폼